Build a Cloud | DIY Cloud Computing - Forum Kunena Site Syndication http://buildacloud.org/ Thu, 10 Jan 2013 02:53:45 +0000 Kunena 1.6 http://buildacloud.org/components/com_kunena/template/default/images/icons/rss.png Build a Cloud | DIY Cloud Computing - Forum http://buildacloud.org/ en-gb Subject: Unable to add KVM host on CloudStack - by: anilsingh http://buildacloud.org/forum/5-installation/13043-unable-to-add-kvm-host-on-cloudstack.html#13043 http://buildacloud.org/forum/5-installation/13043-unable-to-add-kvm-host-on-cloudstack.html#13043 I am not able to add kvm host on cloudstack. Please find the details below

System Details:
Ubuntu 12.04 +KVM
root# uname -a
Linux anil-Samsung-Desktop-System 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Downloaded the Cloudstack4 fron hudson:
jenkins.cloudstack.org/ ---->Latest build for ubuntu

1) Installed Management server
2) Installed Database
3) Installed Agent for KVM

Login on CloudStack UI. I am able to add zone, cluster, pod and secondary storage.
But facing the issue while adding KVM host on the cloudstack.


Exception:

com.cloud.exception.DiscoveryException: Unable to add the host
at com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:737)
at com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:544)
at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:140)
at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
at com.cloud.api.ApiServer.queueCommand(ApiServer.java:543)
at com.cloud.api.ApiServer.handleRequest(ApiServer.java:422)
at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:304)
at com.cloud.api.ApiServlet.doGet(ApiServlet.java:63)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:615)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:744)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2274)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:679)
2012-12-24 17:29:31,071 WARN [cloud.api.ApiDispatcher] (catalina-exec-23:null) class com.cloud.api.ServerApiException : Unable to add the host

I have verified this:

1) ssh is installed on ubuntu system
2) below is the content from the /etc/network/interfaces


auto lo
iface lo inet loopback
face eth0 inet static
address 107.108.188.164
netmask 255.255.255.0
gateway 107.108.188.1
dns-nameservers 165.213.246.161
bridge_ports eth0
bridge_fd 9
bridge_hello 2
bridge_maxage 12
bridge_stp off]]>
Installation Mon, 24 Dec 2012 12:30:38 +0000
Subject: Is it possible to deploy cloud with Only L2 switch - by: sudheer varma http://buildacloud.org/forum/5-installation/13042-is-it-possible-to-deploy-cloud-with-only-l2-switch.html#13042 http://buildacloud.org/forum/5-installation/13042-is-it-possible-to-deploy-cloud-with-only-l2-switch.html#13042 Installation Sun, 23 Dec 2012 18:33:08 +0000 Subject: No internet connection - by: lightluke http://buildacloud.org/forum/5-installation/13041-no-internet-connection.html#13041 http://buildacloud.org/forum/5-installation/13041-no-internet-connection.html#13041
The SSVM Check.sh script fails at pinging the first DNS server.

Any thoughts on this?]]>
Installation Wed, 19 Dec 2012 12:30:51 +0000