Welcome, Guest
Username: Password: Remember me
Archived CloudStack Forums for reference purposes please direct all future inquiries to the Apache CloudStack mailing lists.

incubator.apache.org/cloudstack/mailing-lists.html
  • Page:
  • 1

TOPIC: AD Login Issues

AD Login Issues 10 months 2 weeks ago #12425

  • tombean
  • tombean's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Karma: 0
I am having a few problems setting up LDAP login with my AD server.

I have run the following command on the cloudstack server:
http://cloudstack.cwpintranet.com:8096/?command=ldapConfig
&hostname=192.168.47.1
&searchbase=OU%3DCWP%20IT%20Team%2COU%3DLAN%20Users%2CDC%3Dcwpintranet%2CDC%3Dcom
&queryfilter=%28%26%28displayName%3D%25u%29%29
&binddn=CN%3DTom%20Bean%2COU%3DCWP%20IT%20Team%2COU%3DLAN%20Users%2CDC%3Dcwpintranet%2CDC%3Dcom
&bindpass=password
&port=389
&response=json

This seems to execute correctly using curl and I get no error responses, I can see the request hitting the AD server and authenticating correctly.

I have then created an user account with the same display name as in AD, with a slightly different password than the one stored in AD, when I try to login I can see the following error in the cloud-management.log file:
2012-08-28 16:02:04,168 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-12:null) Attempting to log in user: tomb in domain 2
2012-08-28 16:02:04,169 DEBUG [server.auth.MD5UserAuthenticator] (catalina-exec-12:null) Retrieving user: tomb
2012-08-28 16:02:04,172 DEBUG [server.auth.MD5UserAuthenticator] (catalina-exec-12:null) Password does not match
2012-08-28 16:02:04,172 DEBUG [server.auth.LDAPUserAuthenticator] (catalina-exec-12:null) Retrieving user: tomb
2012-08-28 16:02:04,211 WARN  [server.auth.LDAPUserAuthenticator] (catalina-exec-12:null) Unknown error encountered null
2012-08-28 16:02:04,212 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-12:null) Unable to authenticate user with username tomb in domain 2
2012-08-28 16:02:04,212 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-12:null) User: tomb in domain 2 has failed to log in

Unkown error encountered null doesnt really help...

I can still see cloudstack connecting to my AD server correctly so not sure what is going on or how to fix this.
The administrator has disabled public write access.

Re: AD Login Issues 9 months 2 weeks ago #12728

  • lutix
  • lutix's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
I tried something very similar to what you're doing and it worked fine. I'm sure you have already done this but can you double check the displayName, or maybe change your query syntax to use email
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.289 seconds
About BuildaCloud.org Resources Site Info

Build a Cloud.org is a resource for those users who want to build cloud computing software with both open source and proprietary software.